NexentaStor Community Edition

October 10, 2010 at 6:56 pm Leave a comment

Recently, I posted about a few new NAS distributions that I wanted to look into further.  Today, I put together some spare parts to try out the NexentaStor Community Edition (version 3.03).

My test machine consisted of a Core2Quad processor, 2 GB of RAM, a 160 GB drive (for the OS) and two 500 GB drives for data.

Installation went smoothly.  One thing to note is that when it offers to set up “up to three” drives during the OS install, it’s just referring to the OS.  It is nice that it will automatically set itself up in a redundant mode.

After the OS is installed and you’ve set your IP, you bring up the web GUI and finish the install.  I had trouble getting my two 500 GB drives in a Mirror.  Using Chrome, the “Redundancy Type” pull down is empty.  I tried in Firefox and Safari also.  The pull down showed options there, but all were grayed out except the “None” option.  After trying various methods to see if I could unlock the Mirror option, I continued to create the volume using the “Force creation” checkbox. Update: Through some more testing, I found that you must highlight all the disks that you want in a mirror or RAID set at once, then hit the pull-down and the appropriate options will be available (in Safari at least), then add them.

After this, I created the folder, and the “Wizard” that was guiding me through these steps was about done.  In order to actually share anything, you must go to the Data Management Menu, select Shares, then check the box in the CIFS column.  The other options on this screen are NFS, FTP, RSYNC, WebDAV and Index (to create an indexer for that folder).

I next attempted to connect from my Mac, without success.  Even though the CIFS settings for this share had “Anonymous Read-Write” checked, I couldn’t connect in Guest mode.  Update: Umm… Found out that their idea of “Anonymous Read-Write” isn’t the same as mine…  In Nexenta, it means you use a username of “smb” and password of “nexenta”.  Not what I was expecting, but it worked.  Finally, I added a user and was able to connect, but still could not write.

Through the WebGUI, I went to edit the Folder and “Added Permissions for Group” for the staff group (the one my new user was a member of).  After that, I could write to the share and delete files without a problem.

I copied 1.06 GB to the share.  This took much, much longer than I anticipated  About 10 minutes later, the 1 GB copy (5 files, about 200 MB each) was complete.  About 1.5 – 2 MB/second isn’t exactly speedy.  I had enabled deduplication and compression, so that may have something to do with the speed, but this was shockingly slow to me.

I deleted those files, disabled compression, and recopied them over.  This time it was somewhat faster, at about 6 minutes.  That’s still excruciatingly slow compared to my ReadyNAS Pro or even my Drobo-FS.

I’ve read that Realtek network chips aren’t the best with Nexenta, and since I’m not sure what my motherboard has, I grabbed an Intel 1000GT and dropped it in.  But, it didn’t help.

Perhaps my issues are related to my inexperience using the product, or perhaps my spare hardware has some actual hardware issues, or it isn’t quite compatible with OpenSolaris (on which NexentaStor is based) .  I plan to try unRAID with this same hardware, so we’ll see if it works out better.

Update: I installed a fresh VM of Nexenta to try to take the hardware out of the equation.  This VM had 1 core (that runs at a faster clock speed than the C2Q I originally tested with) and 2GB of RAM  It took almost 7 minutes to copy my test files (same ones as before).  This was with a Mirror set, and deduplicate set to “verify”, which uses a weaker hash algorithm to look for duplicate data (making it faster), but if it finds what it thinks is duplicate data, it will actually verify both blocks contain the same data.  I wasn’t going for exact duplicate settings of my previous test, just trying to put together something to see if it was reasonably fast.  About 2.5 MB/sec is still very disappointing…

Advertisements

Entry filed under: Networking.

Other storage options CheckPoint/Sofaware FlashForward

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Trackback this post  |  Subscribe to the comments via RSS Feed


Calendar

October 2010
S M T W T F S
« Sep   Dec »
 12
3456789
10111213141516
17181920212223
24252627282930
31  

Most Recent Posts


%d bloggers like this: